Jump to content

GDTF Forum

Different dimension between 3ds and builder


Paolo.Prolights
 Share

Recommended Posts

Hi everyone, I'm starting to build some test fixtures and I'm having problems with the size of the models I import into the builder. I imported a simple 200x200x200 mm cube and checked the "Use File Dimension" option. Once the model is imported I see the correct measurements in the 3d view, but in the left view where the dimensions in mm are shown I have scaled values, to be exact I have 7.9x7.9x7.9 mm instead of 200x200x200 mm. The cube was created in Sketchup and exported in 3ds format, keeping the scale 1: 1 and with the software set in mm. I did this test because with our existing 3ds in various formats (skp, dwg, rvt) I always have the correct measurements in the 3d view but always wrong measurements in the left view where the object specifications are found. If I try to load these GDTF files into GrandMA3 the objects are displayed according to the measurements present in the left view where there are the specifications of the object. I created a cube test to test an object with few vertices but the result is the same. I enclose below two images to follow relating to this test. Do you have any suggestions? Can you tell me what I'm doing wrong? I hope I've been clear.

Thanks

Best Regards

1.png

2.png

Prova_cubo.3ds

Link to comment
Share on other sites

Yes, I have observed the same thing in how the builder does not respect the Export's Size or Dimension.  You need to build/EXPORT your 3DS files in MM instead of Meters[at least in my personal experience].....the builder seems to default to MM when bringing in a file, no matter how you check the boxes.

 

I utilize Cinema4D for all my 3D modeling work.  Doesn't matter how I 'freeze' the Transforms, the web builder has a mind of it's own with respect to Units used.

Good luck!

 

NB: I have done lot's of Conversion work before....drop me a PM and we'll chat about terms?!?  I have a valid Driver's License for C4D, lol.

Edited by David "Rex" Whalen
Link to comment
Share on other sites

  • 4 months later...

I made similar experience with my own 3ds exporter - the 3ds format does not store any scaling units, only factors. The Masterscale chunk  is for defining the units, but the conversation to the builder is always meters to millimeters. I have the same issues the other way around - if I export a 3ds from vectorworks, my importer scales it up by factor 1000

Link to comment
Share on other sites

  • 3 months later...

The problem is that the 3DS format itself is unitless. It has no way to specify a real size.

There is no formal specification or standard for 3DS, and so there is no accepted scale factor at all.
So of course, every application that uses 3DS does it their own way.

The majority of CAD and 3D modelling software allows the user to choose whatever units they deem most appropriate when exporting to unitless formats like 3DS.

Weirdly the Vectorworks 3DS exporter doesn't do this. VW has arbitrarily decided on mm, so you have to manually work out the scale factors if you need a 3DS export to be in metres or inches. Sadly this isn't documented or mentioned in the 3DS exporter dialog.

The GDTF Builder has arbitrarily decided that all 3DS files are drawn at a scale of 1 unit == 1 mm, presumably because Vectorworks happens to do that.
This is of course often going to be wrong!
Applications consuming unitless formats (like 3DS) require a UI for the user can specify which units they exported in.

This is another example of why the 3DS format is not suitable for use in GDTF or MVR, and should be deprecated ASAP.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.